Install older version of PHP in CentOS

DPU asked:

There is a web server with CentOS 6.2, Apache 1.3.12 and PHP 4.0.1pl2. It was hosting a web site and now I am trying to host this site on CentOS 6.5, but the site is not working properly. Is it because of newer version of PHP 5.3 and Apache? So, should I install the older version of PHP 4.0.1pl2?

My answer:


No. Absolutely NOT. You should NOT allow such an ancient version of PHP on any network, especially not on the Internet. It’ll have a lifetime of minutes before it’s hacked.

Instead, update or replace the PHP application.


View the full question and answer on Server Fault.

Creative Commons License
This work is licensed under a Creative Commons Attribution-ShareAlike 3.0 Unported License.