Unable to install automake1.9

Kevin S asked:

I am not able to install automake1.9 on Debian 8. While running apt-get install automake1.9 I am getting Unable to locate package automake1.9 error.

I have tried updating repo list but that also did not help

Output of apt-get install automake1.9

root@serv1:~# apt-get install automake1.9
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package automake1.9
E: Couldn't find any package by regex 'automake1.9'
root@serv1:~#

Content in sources.list
# deb http://mirrors.linode.com/debian/ jessie main

deb http://mirrors.linode.com/debian/ jessie main
deb-src http://mirrors.linode.com/debian/ jessie main

# jessie-updates, previously known as 'volatile'
deb http://mirrors.linode.com/debian/ jessie-updates main
deb-src http://mirrors.linode.com/debian/ jessie-updates main

deb http://ftp.us.debian.org/debian/ jessie main contrib non-free
deb-src http://ftp.us.debian.org/debian/ jessie main contrib non-free

deb http://security.debian.org/ jessie/updates main contrib non-free
deb-src http://security.debian.org/ jessie/updates main contrib non-free

I have tried all possible option by changing repo list and also searching on google but did not find any solution.

Do I need to add or update anything in the sources.list file or install it manually?

My answer:


Why are you trying to install such an ancient version of automake? Are you following a bad tutorial?

This old version of automake was removed from Debian and last appeared in Debian wheezy.

You probably need to be using a current version of automake instead. At least, you need to be viewing whatever instructions you were following with a great deal of skepticism.


View the full question and answer on Server Fault.

Creative Commons License
This work is licensed under a Creative Commons Attribution-ShareAlike 3.0 Unported License.