Bad response when try install opcache

Jos asked:

I have problem for install zendopcache

I try 1 time and other and always have the same result i don´t know what it´s bad because this can install with php 5.6 , thanks and also i delete and clean yum etc and the same response

>  [root@cp ~]# yum install php-pecl-zendopcache
>     Loaded plugins: fastestmirror, security
>     Setting up Install Process
>     Loading mirror speeds from cached hostfile
>     Excluding mirror: mirror.de.leaseweb.net
>     Excluding mirror: mirror.nl.leaseweb.net
>      * epel: mirror.23media.de
>     Resolving Dependencies
>     --> Running transaction check
>     ---> Package php-pecl-zendopcache.x86_64 0:7.0.5-2.el6 will be installed
>     --> Processing Dependency: php(zend-abi) = 20090626 for package: php-pecl-zendopcache-7.0.5-2.el6.x86_64
>     --> Processing Dependency: php(api) = 20090626 for package: php-pecl-zendopcache-7.0.5-2.el6.x86_64
>     --> Finished Dependency Resolution
>     Error: Package: php-pecl-zendopcache-7.0.5-2.el6.x86_64 (epel)
>                Requires: php(zend-abi) = 20090626
>                Installed: php-common-5.6.33-1.el6.remi.x86_64 (@remi-php56)
>                    php(zend-abi) = 20131226-64
>                Available: php-common-5.3.3-49.el6.x86_64 (base)
>                    php(zend-abi) = 20090626
>     Error: Package: php-pecl-zendopcache-7.0.5-2.el6.x86_64 (epel)
>                Requires: php(api) = 20090626
>                Installed: php-common-5.6.33-1.el6.remi.x86_64 (@remi-php56)
>                    php(api) = 20131106-64
>                Available: php-common-5.3.3-49.el6.x86_64 (base)
>                    php(api) = 20090626
>      You could try using --skip-broken to work around the problem
>      You could try running: rpm -Va --nofiles --nodigest
>     [root@cp ~]#

I try many times and i try all and i don´t know what i can do for fix this, thanks for the help

Actually in server use Centos 6 64 bits, and run php 5.6

My answer:


Zend OPcache is included with PHP 5.5 and later (and as from Remi) and is already installed on your system. You do not need to install the PECL package, which is only for PHP 5.5 or earlier.


View the full question and answer on Server Fault.

Creative Commons License
This work is licensed under a Creative Commons Attribution-ShareAlike 3.0 Unported License.