Josh Mountain asked:
On my old server I used php-xml to generate some xml sitemaps. On my new server I found out php-xml isn’t installed. I did ‘yum install php-xml’ but I get the following error:
--> Running transaction check ---> Package php-common.i686 0:5.2.17-1.el6.art will be updated --> Processing Dependency: php-common = 5.2.17-1.el6.art for package: php-mhash-5.2.17-1.el6.art.i686 ---> Package php-devel.x86_64 0:5.2.17-1.el6.art will be updated ---> Package php-devel.x86_64 0:5.3.3-14.el6_3 will be an update --> Finished Dependency Resolution Error: Package: php-mhash-5.2.17-1.el6.art.i686 (@/php-mhash-5.2.17-1.el6.art.i686) Requires: php-common = 5.2.17-1.el6.art Removing: php-common-5.2.17-1.el6.art.i686 (@/php-common-5.2.17-1.el6.art.i686) php-common = 5.2.17-1.el6.art Updated By: php-common-5.3.3-14.el6_3.x86_64 (updates) php-common = 5.3.3-14.el6_3 Available: php-common-5.3.3-3.el6_2.8.x86_64 (base) php-common = 5.3.3-3.el6_2.8 You could try using --skip-broken to work around the problem You could try running: rpm -Va --nofiles --nodigest
What does this mean exactly? Do I need to install php-mhash first? Any help is much appreciated.
For reasons I can’t even begin to guess, your server is running an ancient and unsupported version of PHP from a third party repository (art? Never heard of it.) and the system wants to update PHP to the current version provided by Enterprise Linux.
Given that PHP 5.2 is past EOL and completely unsupported, you should have gotten rid of it long ago. Your best bet is to update the system to the current release of PHP shipped by EL (or a later version), and then install the additional packages you want.
This work is licensed under a Creative Commons Attribution-ShareAlike 3.0 Unported License.