Dependency and duplicates error, during installation of HHVM on Redhat

SuperKrish asked:

I installed HHVM on Redhat-6.6 (Santiago) using yum install hhvm, But it returns Following errors

Error: Package: gcc-java-4.4.7-17.el6.x86_64 (rhel-6-server-rpms)
 Requires: gcc = 4.4.7-17.el6
             Removing: gcc-4.4.7-11.el6.x86_64 (@rhel-x86_64-server-6)
                            gcc = 4.4.4-15.el6
                            gcc = 4.4.7-11.el6
                        Updated By: gcc-4.8.2-8.el6.x86_64 (hop5)
                            gcc = 4.8.2-8.el6
                        Available: gcc-4.4.4-13.el6.x86_64 (rhel-6-server-rpms)
                            gcc = 4.4.4-13.el6
                        Available: gcc-4.4.5-6.el6.x86_64 (rhel-6-server-rpms)
                            gcc = 4.4.5-6.el6
                            gcc = 4.4.4-15.el6
                        Available: gcc-4.4.6-3.el6.x86_64 (rhel-6-server-rpms)
                            gcc = 4.4.6-3.el6
                            gcc = 4.4.4-15.el6
                        Available: gcc-4.4.6-4.el6.x86_64 (rhel-6-server-rpms)
                            gcc = 4.4.6-4.el6
                            gcc = 4.4.4-15.el6
                        Available: gcc-4.4.7-3.el6.x86_64 (rhel-6-server-rpms)
                            gcc = 4.4.7-3.el6
                            gcc = 4.4.4-15.el6
                        Available: gcc-4.4.7-4.el6.x86_64 (rhel-6-server-rpms)
                            gcc = 4.4.7-4.el6
                            gcc = 4.4.4-15.el6
                        Available: gcc-4.4.7-4.1.el6_5.x86_64 (rhel-6-server-rpms)
                            gcc = 4.4.7-4.1.el6_5
                            gcc = 4.4.4-15.el6_5
                        Available: gcc-4.4.7-16.el6.x86_64 (rhel-6-server-rpms)
                            gcc = 4.4.7-16.el6
                            gcc = 4.4.4-15.el6
                        Available: gcc-4.4.7-17.el6.x86_64 (rhel-6-server-rpms)
                            gcc = 4.4.7-17.el6
                            gcc = 4.4.4-15.el6
                        Available: gcc-4.6.3-2.el6.x86_64 (hop5)
                            gcc = 4.6.3-2.el6
                        Available: gcc-4.8.2-7.el6.x86_64 (hop5)
                            gcc = 4.8.2-7.el6  You could try using --skip-broken to work around the problem
             ** Found 8 pre-existing rpmdb problem(s), 'yum check' output follows: 12:dhcp-common-4.1.1-51.P1.el6.x86_64 is a duplicate with
             12:dhcp-common-4.1.1-43.P1.el6_6.1.x86_64
             glibc-common-2.12-1.192.el6.x86_64 is a duplicate with
             glibc-common-2.12-1.149.el6_6.5.x86_64
             glibc-common-2.12-1.192.el6.x86_64 has missing requires of glibc =
             ('0', '2.12', '1.192.el6') kernel-headers-2.6.32-642.3.1.el6.x86_64 is
             a duplicate with kernel-headers-2.6.32-504.12.2.el6.x86_64
             libgcc-4.4.7-17.el6.x86_64 is a duplicate with
             libgcc-4.4.7-11.el6.x86_64 ncurses-base-5.7-4.20090207.el6.x86_64 is a
             duplicate with ncurses-base-5.7-3.20090208.el6.x86_64
             nss-softokn-freebl-3.14.3-23.3.el6_8.x86_64 is a duplicate with
             nss-softokn-freebl-3.14.3-22.el6_6.x86_64 tzdata-2016f-1.el6.noarch is
             a duplicate with tzdata-2015a-1.el6.noarch

I tried The following

yum clean all
rpm --rebuilddb
yum update

My answer:


Your system has multiple problems here that need to be fixed:

  • First, you have rpmdb problems (duplicate packages) because a previous run of yum was interrupted. You can try to clean this up with:

    yum-complete-transaction   # which may fail
    package-cleanup --cleandupes
    
  • Second, your system has a third party repository named hop5 which is providing packages that conflict with the packages provided by RHEL. This repository needs to be disabled or removed. If you were actually using packages from this repository, you should instead get them from official RHEL sources, or for third party packages, a more reliable source.

    yum-config-manager --disable hop5
    
  • Finally, your system appears to be locked onto RHEL 6.6, and you need to update to the current release (today 6.8). You can fix this with:

    subscription-manager release --unset
    yum --releasever=6.8 update
    

View the full question and answer on Server Fault.

Creative Commons License
This work is licensed under a Creative Commons Attribution-ShareAlike 3.0 Unported License.