Why is my 64-bit system downloading redundant 32 and 64 bit versions during update?

Lee Gildemeester asked:

I’m unable to complete yum update, and if I’m reading this correctly my system thinks it’s both 32 and 64 bit.

...
---> Package librevenge.x86_64 0:0.0.2-2.el7 will be installed
---> Package libsepol.i686 0:2.5-8.1.el7 will be installed
---> Package mythes.x86_64 0:1.2.3-7.el7 will be installed
---> Package pcre.i686 0:8.32-17.el7 will be installed
--> Processing Dependency: libstdc++.so.6 for package: pcre-8.32-17.el7.i686
--> Processing Dependency: libstdc++.so.6(CXXABI_1.3) for package: pcre-8.32-17.el7.i686
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4) for package: pcre-8.32-17.el7.i686
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4.9) for package: pcre-8.32-17.el7.i686
---> Package zlib.i686 0:1.2.7-17.el7 will be installed
--> Running transaction check
---> Package gnome-classic-session.noarch 0:3.26.2-3.el7 will be an update
--> Processing Dependency: gnome-shell-extension-top-icons = 3.26.2-3.el7 for package: gnome-classic-session-3.26.2-3.el7.noarch
---> Package libcap-ng.i686 0:0.7.5-4.el7 will be installed
---> Package libstdc++.i686 0:4.8.5-28.el7 will be installed
--> Finished Dependency Resolution
Error: Package: gnome-classic-session-3.26.2-3.el7.noarch (rhel-7-server-rpms)
           Requires: gnome-shell-extension-top-icons = 3.26.2-3.el7
           Available: gnome-shell-extension-top-icons-3.14.4-13.el7.noarch (rhel-7-server-e4s-optional-rpms)
               gnome-shell-extension-top-icons = 3.14.4-13.el7
           Available: gnome-shell-extension-top-icons-3.14.4-21.el7.noarch (rhel-7-server-e4s-optional-rpms)
               gnome-shell-extension-top-icons = 3.14.4-21.el7
           Available: gnome-shell-extension-top-icons-3.22.2-10.el7.noarch (rhel-7-server-e4s-optional-rpms)
               gnome-shell-extension-top-icons = 3.22.2-10.el7
**********************************************************************
Dependency resolving failed due to missing dependencies.
Some repositories on your system are disabled, but yum can enable them
and search for missing dependencies. This will require downloading
metadata for disabled repositories and may take some time and traffic.
**********************************************************************

Enable all repositories and try again? [y/N]: y
--> Running transaction check
---> Package gnome-classic-session.noarch 0:3.26.2-3.el7 will be an update
--> Processing Dependency: gnome-shell-extension-top-icons = 3.26.2-3.el7 for package: gnome-classic-session-3.26.2-3.el7.noarch
---> Package kernel.x86_64 0:3.10.0-327.44.2.el7 will be erased
---> Package libreoffice-langpack-en.x86_64 1:5.0.6.2-15.el7_4 will be installed
---> Package mythes-en.noarch 0:3.0-13.el7 will be installed
--> Running transaction check
---> Package gnome-shell-extension-top-icons.noarch 0:3.26.2-3.el7 will be installed
--> Finished Dependency Resolution
Error:  Multilib version problems found. This often means that the root
       cause is something else and multilib version checking is just
       pointing out that there is a problem. Eg.:

         1. You have an upgrade for mesa-libglapi which is missing some
            dependency that another package requires. Yum is trying to
            solve this by installing an older version of mesa-libglapi of the
            different architecture. If you exclude the bad architecture
            yum will tell you what the root cause is (which package
            requires what). You can try redoing the upgrade with
            --exclude mesa-libglapi.otherarch ... this should give you an error
            message showing the root cause of the problem.

         2. You have multiple architectures of mesa-libglapi installed, but
            yum can only see an upgrade for one of those architectures.
            If you don't want/need both architectures anymore then you
            can remove the one with the missing update and everything
            will work.

         3. You have duplicate versions of mesa-libglapi installed already.
            You can use "yum check" to get yum show these errors.

       ...you can also use --setopt=protected_multilib=false to remove
       this checking, however this is almost never the correct thing to
       do as something else is very likely to go wrong (often causing
       much more problems).

       Protected multilib versions: mesa-libglapi-17.0.1-6.20170307.el7.i686 != mesa-libglapi-17.2.3-8.20171019.el7.x86_64

I’ve attempted

package-cleanup --dupes
package-cleanup --cleandupes
yum clean all
yum update

I’ve rebooted multiple times, and I’ve downloaded mesa-libglapi-18.0.0-4.fc29.x86_64.rpm and tried to update the package manually using both yum localinstall and rpm -Uvh, both failed

 yum localinstall:
 ...
       Protected multilib versions: mesa-libglapi-17.2.3-8.20171019.el7.x86_64 != mesa-libglapi-17.0.1-6.20170307.el7.i686
Error: Protected multilib versions: mesa-libglapi-17.2.3-8.20171019.el7.x86_64 != mesa-libglapi-18.0.0-4.fc29.x86_64

$ rpm -Uvh mesa-libglapi-18.0.0-4.fc29.x86_64.rpm 
warning: mesa-libglapi-18.0.0-4.fc29.x86_64.rpm: Header V3 RSA/SHA256 Signature, key ID 429476b4: NOKEY
error: Failed dependencies:
    mesa-libglapi = 17.0.1-6.20170307.el7 is needed by (installed) mesa-libOSMesa-17.0.1-6.20170307.el7.x86_64
    mesa-libglapi = 17.0.1-6.20170307.el7 is needed by (installed) mesa-libGL-17.0.1-6.20170307.el7.x86_64
    mesa-libglapi = 17.0.1-6.20170307.el7 is needed by (installed) mesa-libgbm-17.0.1-6.20170307.el7.x86_64

My answer:


When you see a “Protected multilib versions” message, you need to run yum distro-sync instead of yum update here.

BTW, in RHEL 7.5, the gnome-shell-extension-top-icons package was moved from rhel-7-server-rpms to rhel-7-server-optional-rpms, so you need to make sure you have the optional channel enabled before upgrading existing GUI systems from 7.x to 7.5.


View the full question and answer on Server Fault.

Creative Commons License
This work is licensed under a Creative Commons Attribution-ShareAlike 3.0 Unported License.